Mail8 - Server Down
Incident Report for Cartika
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 09:58 EDT
Update
We are continuing to investigate this issue.
Posted Oct 23, 2019 - 09:58 EDT
Update
We are continuing to investigate this issue.
Posted Oct 23, 2019 - 09:10 EDT
Investigating
We are currently investigating this issue.
Posted Oct 23, 2019 - 09:09 EDT
This incident affected: Cartika Dallas (Shared Email) and Cartika Toronto (Shared Email).