MAIL8 Connectivity Issues
Incident Report for Cartika
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 12:28 EDT
Investigating
Hello,

We are experiencing connectivity issues with our mail server 'mail8.hspheredns.com', our team is investigating this issue. Please check our page regularly for updates.

Thank you for your patience and we apologize for the invoicenence.
Posted Sep 13, 2021 - 09:12 EDT
This incident affected: Cartika Dallas (Shared Email).