Dallas - Microsoft Exchange Connectivity Issues
Incident Report for Cartika
Resolved
This incident has been resolved
Posted Mar 07, 2020 - 22:04 EST
Monitoring
Our Engineering team has implemented an in-place fix, and all users should now be able to connect to Microsoft Exchange services at this time.

We apologize for any inconvenience and thank you for your patience throughout this process.
Posted Mar 07, 2020 - 19:50 EST
Investigating
Our exchange team is currently investigating an issue with client access for Cloud Email clusters. At this time, users may experience issues using OWA or Exchange mail clients to connect to Cloud Email clusters. We apologize for the inconvenience and will share an update once we have more information.
Posted Mar 07, 2020 - 15:59 EST
This incident affected: Cartika Dallas (Cloud Email).